Konfigurasi 6to4 Tunneling pada Cisco, Juniper, dan Mikrotik (IPv6 over IPv4 Protocol 41)


6to4 tunneling adalah metode tunneling peer-to-peer (site-to-site) yang digunakan untuk membawa paket IPv6 di dalam paket IPv4. Jadi paket IPv6 dienkapsulasi oleh IPv4 header.

Quick links:

  1. Konfigurasi 6to4 Tunneling pada Cisco
  2. Konfigurasi 6to4 Tunneling pada Juniper
  3. Konfigurasi 6to4 Tunneling pada Mikrotik
  4. Catatan Penting: 6to4 Tunneling dengan IPv4 Publik dari Static NAT

Ketika kita mempunyai jaringan IPv6 kemudian kita ingin melewatkan traffic IPv6 kita melalui jaringan yang hanya mempunyai IPv4, kita bisa menggunakan tunneling IPv6 over IPv4 atau biasa disebut 6in4 atau 6to4.

Metode tunneling 6in4 bisa kamu gunakan ketika ingin menghubungkan jaringan IPv4-only ke jaringan IPv6, contohnya dengan menggunakan tunnelbroker.net. Di situ, kamu akan mendapatkan prefix IPv6 dengan prefix-length /48 yang bisa kamu gunakan untuk membuat jaringan IPv6.

Baca juga:

Cara kerja 6in4 tunneling yaitu dengan mengenkapsulasi paket IPv6 di dalam paket IPv6. Paket IPv6 tersebut memiliki nomor protokol 41 pada protokol IPv4. Dengan demikian, paket IPv6 tersebut bisa ditransmisikan pada jaringan yang hanya mendukung IPv4.

Berikut adalah ilustrasi sebuah paket IPv6 yang dienkapsulasi oleh IPv4 header.

Dan berikut adalah contoh urutan header yang diambil dari paket asli. Kita bisa lihat bahwa paket IPv6 dienkapsulasi oleh IPv4 header.

Ini adalah topologi yang akan kita gunakan untuk lab kali ini, hanya 2 router yang terhubung langsung ke jaringan internet.



Konfigurasi 6to4 Tunneling di Cisco

Nilai 2000::xx/y pada routing silakan sesuaikan dengan prefix IPv6 yang akan kamu routing melalui interface tunnel 6to4.

HE(config)# interface Tunnel0
HE(config-if)# ipv6 address 2001:470:35:3f::1/64
HE(config-if)# tunnel source 216.218.221.42
HE(config-if)# tunnel destination 157.230.250.14
HE(config-if)# tunnel mode ipv6ip
HE(config)# ipv6 route 2000::xx/y Tunnel0

GW(config)# interface Tunnel0
GW(config-if)# ipv6 address 2001:470:35:3f::2/64
GW(config-if)# tunnel source 157.230.250.14
GW(config-if)# tunnel destination 216.218.221.42
GW(config-if)# tunnel mode ipv6ip
GW(config)# ipv6 route 2000::xx/y Tunnel0



Konfigurasi 6to4 Tunneling di Juniper

Nilai 2000::xx/y pada routing silakan sesuaikan dengan prefix IPv6 yang akan kamu routing melalui interface tunnel 6to4.

[edit interfaces ip-0/1/0 unit 0]
lab@HE# set tunnel source 216.218.221.42
lab@HE# set tunnel destination 157.230.250.14
lab@HE# set family inet6 address 2001:470:35:3f::1/64

[edit routing-options rib inet6.0]
lab@GW# set static route 2000::xx/y next-hop 2001:470:35:3f::2

[edit interfaces ip-0/1/0 unit 0]
lab@GW# set tunnel source 157.230.250.14
lab@GW# set tunnel destination 216.218.221.42
lab@GW# set family inet6 address 2001:470:35:3f::2/64

[edit routing-options rib inet6.0]
lab@GW# set static route 2000::xx/y next-hop 2001:470:35:3f::1

(Opsional) Jika menggunakan Juniper seri SRX, ubah IPv6 forwarding ke packet-based.
[edit]
lab@Juniper# set forwarding-options family inet6 mode packet-based


Konfigurasi 6to4 Tunneling di Mikrotik

Nilai 2000::xx/y pada routing silakan sesuaikan dengan prefix IPv6 yang akan kamu routing melalui interface tunnel 6to4.

# Konfigurasi pada Router HE
[admin@HE]> /interface 6to4 add comment="6to4 to GW" local-address=216.218.221.42 name=to-GW remote-address=157.230.250.14
[admin@HE]> /ipv6 address add address=2001:470:35:3f::1/64 advertise=no interface=to-GW
[admin@HE]> /ipv6 route add dst-address=2000::xx/y gateway=2001:470:35:3f::2

# Konfigurasi pada Router GW
[admin@GE]> /interface 6to4 add comment="6to4 to HE" local-address=157.230.250.14 name=to-HE remote-address=216.218.221.42
[admin@GE]> /ipv6 address add address=2001:470:35:3f::2/64 advertise=no interface=to-HE
[admin@GE]> /ipv6 route add dst-address=2000::xx/y gateway=2001:470:35:3f::1



Catatan Penting: IPv4 Public hasil dari Static NAT

Jika teman-teman menggunakan IPv4 publik yang berasal dari source NAT, dalam arti perangkat teman-teman hanya punya IPv4 private , tetapi mendapatkan IPv4 publik dari static NAT (bukan source NAT saja atau destination NAT saja).

Jika kasusnya seperti pada router GW pada gambar di atas, di mana router GW mendapat IPv4 publik (157.230.250.14) dari hasil static NAT pada router NAT. Maka, di bagian local-address atau source address diisi dengan IPv4 yang terpasang langsung di interface perangkat teman-teman, yakni IPv4 private (dalam contoh di atas 10.13.0.21).

Akan tetapi di router pasangannya, remote-address atau destination address tetap IPv4 publik milik router GW (157.230.250.14).

# Router GW
local-address=10.13.0.21
remote-address=216.128.221.42

# Router HE
local-address=216.128.221.42
remote-address=157.230.250.14

Demikian, cara konfigurasi 6to4 tunneling pada perangkat mirkotik, juniper, dan cisco. 6to4 tunneling digunakan untuk membawa paket IPv6 di dalam paket IPv4.

tags: 6to4 tunneling, ipv6 over ipv4 tunneling, konfigurasi 6to4 tunneling cisco, konfigurasi 6to4 tunneling juniper, konfigurasi 6to4 tunneling mikrotik, 6to4 mikrotik, 6to4 cisco, 6to4 juniper, konfigurasi hurricae electric, cara mendapatkan IPv6 gratis, cara melewatkan paket ipv6 di dalam paket ipv4, ipv6 over ipv4 cisco, ipv6 over ipv4 juniper, ipv6 over ipv4 mikrotik, konfigurasi 6in4 cisco, konfigurasi 6in4 juniper, konfigurasi 6in4 mikrotik.

Disqus Comments